Lost Incompletes after moving folder

Discuss Shareaza bugs.
Forum rules
Home | Wiki | Rules

Lost Incompletes after moving folder

Postby ceriank » 09 Apr 2011 19:33

I just changed my Downloads and Incomplete folder locations to another drive (Tools/Settings/Downloads), closed Shareaza R8961, moved contents to the new location and reopened Shareaza.
Shareaza knows the hash status, but list all as 0% complete and is starting to re-download again from scratch over the top of my existing partials.
Please tell me there is a quick fix for this... I thought this type of issue was put to rest long ago.

Oh... the 'Assume 100% and Reverify' is not finding the data in the few files I've tried. I've manually viewed the data in some that I know were mostly complete and it is there. Ouch!

[edit]I got it figured out. The .SD files were being read from the new Incomplete folder... but it began creating new .PARTIALS in the old Incomplete folder. I've copied just the original .PARTIAL files back to the original folder. I guess I have to maintain two Incomplete folders until my old download list is finished. I hope this information helps someone avoid some difficulties. Obviously, as a bug fix, it would be good to have the SD look for the PARTIAL in the same folder before creating a new partial in an old location.[/edit]
ceriank
 
Posts: 22
Joined: 13 Jun 2009 17:11

Re: Lost Incompletes after moving folder

Postby old_death » 16 Apr 2011 13:25

This sounds like a bug. It would be cool if you could create a ticket on our bug tracker. :mrgreen:

See our wiki for a link to our tracker (it is liked from the first page).
User avatar
old_death
 
Posts: 1950
Joined: 13 Jun 2009 16:19

Re: Lost Incompletes after moving folder

Postby ceriank » 16 Apr 2011 14:52

Created ticket #155. My first time using the new bug tracker.
ceriank
 
Posts: 22
Joined: 13 Jun 2009 17:11

Re: Lost Incompletes after moving folder

Postby ailurophobe » 17 Apr 2011 00:07

I think this is not a bug, just a known "feature"... LOL. The sd files contain the path of the partial. Which since you copied them over would be the path for the old folder. I'd assume Shareaza is supposed to do the moving itself and handle modifying the sd files to match. Not sure if it does, since I've rarely needed to do this.

As for the merge problem it sounds like a bug/missing feature I ran into earlier. The merge requires that file extensions match. And uses the extension of the actual file, not the .partial extension of the temprary file for the match. This means that you need to rename the partials to correct extension to merge them. Since this was brought up this really should be fixed, the merge should only check the file size and ignore the extension, if the user merges the wrong file... Shareaza should let them, really. At most there should be a "Are you sure?" dialog. Or for a really smart system Shareaza could just use the hashsets it requires for merge to work to verify the file is correct. This could even be done automatically when loading batch torrents. Shareaza could check files of correct sizes in the library to see if they match the hashset and if they do merge them automatically.

Speaking of which, kudos to ryo for the multi-merge commit. Let me tell you, not having that feature can be pretty annoying if you need it...
ailurophobe
 
Posts: 709
Joined: 11 Nov 2009 05:25

Re: Lost Incompletes after moving folder

Postby ceriank » 19 Apr 2011 01:17

My feeling is that 'known features' should be well documented or obvious to be useful. In this case, I could see that if I had simply copied the files that it might make sense for the original .PARTIAL to still be used. However, I moved them instead. What if I had actually deleted the empty original Incomplete folder after I moved the contents... would Shareaza have recreated the folder in the old location? I don't know, but I would think there would be some way to trigger an automatic rediscovery of the .PARTIAL in the currently registered Incomplete folder where the .SDs reside.

BTW, I wasn't using the 'Merge with local file' feature, but the 'Assume 100%' feature, on the incorrect assumption that the .PARTIAL was the old mostly filled, not the new empty one. Then I discovered my error by finding the .PARTIALs in the old location. Ultimately I just copied the original file over the new one (into the old location) and then started Shareaza to perform the 'Assume 100%' on each file again. That worked fine.
ceriank
 
Posts: 22
Joined: 13 Jun 2009 17:11

Re: Lost Incompletes after moving folder

Postby ailurophobe » 19 Apr 2011 19:19

Yeah, there is a reason I put the "feature" in quotation marks... I guess that Shareaza, like most other programs, assumes that the user does not have any direct interaction with its temporary files.
ailurophobe
 
Posts: 709
Joined: 11 Nov 2009 05:25

Re: Lost Incompletes after moving folder

Postby old_death » 21 Apr 2011 09:31

... which is generally a bad assumption, if we can simply take the necessary information from the settings...
User avatar
old_death
 
Posts: 1950
Joined: 13 Jun 2009 16:19

Re: Lost Incompletes after moving folder

Postby siavoshkc » 14 Mar 2013 12:53

Shareaza keeps the path of the incomplete files in sd files. The only way I know to move the incompletes is to 1)copy it to the place you want.
2)In win 7 (I do not support older versions of windows) when you open shareaza you see the list of downloads but 0 progress.
3)Open the properties for each download there you see the name of incomplete file.
4)Copy the name of incomplete file and switch to next tab "advanced?"
5)Select merge with local file and reverify
6)A file select dialogopens up, there you locate the original incompletes folder then paste file name (which is is hash) into search text box (win7 specific) then you should see two files with the same name one with .partial and one with .sd extension.
7)Select the partial file and click ok on any open dialog
8) you should see the content is added to the download
9)Do this for each download
siavoshkc
 
Posts: 347
Joined: 02 Nov 2009 09:37

Re: Lost Incompletes after moving folder

Postby raspopov » 25 Mar 2013 16:02

BTW this issue was fixed.
User avatar
raspopov
Project Admin
 
Posts: 944
Joined: 13 Jun 2009 12:30
Location: Russian Federation


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron